PDA

View Full Version : Contact search not working as expected.



newtonwb
06-17-2010, 05:54 AM
With the Search option set to "Name, company, and Notes":

Names: Search seems to work based on the fact that the "search string" has to match the first part of one of the name fields. If I have a contact with a last name "Last-Name" then searching for "Last" or "last" or "las" will return this contact, But if I search for "Name" it will not.

Company: Search seems to work based on the fact that the "search string" has to match the first part of the company field. If I have a comany with named "My First Company" then searching for "My" or "my" or "m" will return this contact, But if I search for "First" it will not.

Notes: Ditto

? Is this intentional ?

If so, could you please modify this - at least in the "company" and "notes" fields to return records where the "search string" is found in any part of the fields' string?

I hope this makes sense... I thought that it worked that way before the last update...

Thanks,
-William

Eric
06-17-2010, 10:53 AM
William, this makes sense, and we are working on improving the search functionality. Thanks for your feedback!

Jayhawk94
06-20-2010, 12:50 PM
I miss my Palm Pre's method of contact searching, which typically returned a unique result with 3-5 characters: first initial last name. E.g., Bob Smith would be found by typing "bsm". It was quicker, i.e. fewer characters entered, than the current DejaOffice method of using only the first or last name to search with.