PDA

View Full Version : sync changed outlook calendar entries time zone



raroberts
09-13-2011, 10:05 PM
Just updated to dejaoffice 1.12.1 and compainionlink build 4050. The first sync after the upgrades I noticed my all day calendar entries in outlook had changed to 2 day events. When I looked further, it appears the time zone for these entries in outlook changed to "Coordinated Universal Time" and that made them span 2 days. The time zone in calendar entries with less than all day duration correctly have Pacific Time Zone.

Some of the entries in the android calendar were duplicated. The duplicates were set to GMT+1. The dejaoffice calendar had the same duplicated entries but the timezone was set to GMT.

When I enter a new all day event in Outlook, it creates it with Pacific Time Zone. I ran a test by creating a new all day event in Outlook and then did a sync. The new event stayed at Pacific Time.

The release notes for dejaoffice 1.12.1 indicate a new feature called "Time Zone Shift", but I have not found anything more about this feature,,like what it does or how to use it.

Can anyone help?
Thanks

raroberts
09-13-2011, 11:28 PM
I found the answer to some of my issues. I had compainionlink set to create duplicate records if both dejaoffice and office calendar entries had changed. This might have caused the duplicate entries. I found the explanation of Time Zone Shift,,,and turned it off. But I still have the problem of the time zone for some all day entries changing to GMT or coordinated universal time and some events shifting back a day

Thomas
09-14-2011, 07:15 AM
I found the answer to some of my issues. I had compainionlink set to create duplicate records if both dejaoffice and office calendar entries had changed. This might have caused the duplicate entries. I found the explanation of Time Zone Shift,,,and turned it off. But I still have the problem of the time zone for some all day entries changing to GMT or coordinated universal time and some events shifting back a day

Hello raroberts,

Thanks for the update. DO the events that shift have a location associated with them?

raroberts
09-14-2011, 08:53 AM
None of the events have a location

This morning I did a test. I created an all day event in the droid and deja office calendars and an all day repeating event in the droid and dejaoffice calendars. All entries were an all day event on Sept. 14, 2011.

I synced dejaoffice and the phone (via "Read Android Data within dejaoffice). I have not synced with outlook.

Results:
Dejacalendar contains all 4 events as expected, however, the repeating event created within dejaoffice has timezone listed as GMT when I tap the entry and has Pacific time zone listed when I edit the same entry. All other entries seem OK.
The Droid calendar has all events as expected, except the repeating entry created within dejaoffice. That entry is listed on Sept 13 at 5:00 PM Pacific Time. When I edit the entry the start date/time is Sept 14, 12:00 AM and the enddate/time is Sept 14, 12:00 AM, however, underneath each date/time is another entry with Sept 13 5:00 PM and the "all day" box is not checked

Does this help?
Thanks!

Thomas
09-14-2011, 03:08 PM
None of the events have a location

This morning I did a test. I created an all day event in the droid and deja office calendars and an all day repeating event in the droid and dejaoffice calendars. All entries were an all day event on Sept. 14, 2011.

I synced dejaoffice and the phone (via "Read Android Data within dejaoffice). I have not synced with outlook.

Results:
Dejacalendar contains all 4 events as expected, however, the repeating event created within dejaoffice has timezone listed as GMT when I tap the entry and has Pacific time zone listed when I edit the same entry. All other entries seem OK.
The Droid calendar has all events as expected, except the repeating entry created within dejaoffice. That entry is listed on Sept 13 at 5:00 PM Pacific Time. When I edit the entry the start date/time is Sept 14, 12:00 AM and the enddate/time is Sept 14, 12:00 AM, however, underneath each date/time is another entry with Sept 13 5:00 PM and the "all day" box is not checked

Does this help?
Thanks!

Hi Raroberts,

Thanks for the info. I have a couple of clarifying questions for you.

1. What time zone are you located in, and what time zone populates by default when you make a calendar event in DejaOffice? I suspect Pacific but I want to make sure.
2. What Recurrence option did you select for the all day recurring event you created in DejaOffice?
3. This was all done on Droid X. Correct?

raroberts
09-14-2011, 04:00 PM
Yes, Pacific time is the default.
The reoccurance was yearly by date
Yes, it is a driod X

Thomas
09-22-2011, 09:33 AM
Yes, Pacific time is the default.
The reoccurance was yearly by date
Yes, it is a driod X

Hello raroberts,

I have not forgotten about this issue. We hare having problems with our inhouse drodx device, so recreating this in the lab is not possible at the moment. I will provide feedback as soon as I can.

raroberts
09-22-2011, 10:31 AM
Thanks for the update

raroberts
10-04-2011, 11:24 AM
This problem is becoming very annoying. Whenever I put an all day event in outlook, it changes to a 2 day event with the wrong time zone when I sync. It's to the point I will stop syncing,,which is the reason I bought this software. When can I expect a fix?
Thanks

raroberts
10-04-2011, 11:27 AM
sig updated

Hook
10-04-2011, 11:32 AM
It may not help, but I notice beta 1.12.2 is supposed to have addressed some time zone issues, though I don't know if they are specifically your issue. You might try it and see if it helps.

Thomas
10-04-2011, 02:00 PM
It may not help, but I notice beta 1.12.2 is supposed to have addressed some time zone issues, though I don't know if they are specifically your issue. You might try it and see if it helps.

Raroberts,

If you could please check the behavior in 1.12.1 that would be great. I am curious if we have fixed this or have some additional work to do on it.

raroberts
10-04-2011, 06:52 PM
I am using 1.12.1 did you mean 1.12.2?

Thomas
10-05-2011, 08:58 AM
I am using 1.12.1 did you mean 1.12.2?

Yes,
1.12.2beta. Sorry for the typo.

raroberts
10-05-2011, 09:07 AM
I updated to djo 1.12.2

As a test, I entered another all day event in outlook. I synced and the event stayed as it should. However, previously entered all day events were changed to 2 day events and the time zone changed. This didn't happen to every all day event, just a few. I deleted the bad eventsa and recreated. They stayed correct after another sync.

I also recreated the tests described in my post on 9-14. The results are the same.

raroberts
10-05-2011, 09:13 AM
Update,, I deleted the test record I created in outlook. The one that I reported remained correct after a sync. However, after another sync (after I deleted the test record) the test record reappeared in outlook as a 2 day event with the wrong time zone.

Thomas
10-05-2011, 09:19 AM
Update,, I deleted the test record I created in outlook. The one that I reported remained correct after a sync. However, after another sync (after I deleted the test record) the test record reappeared in outlook as a 2 day event with the wrong time zone.

raroberts,

Can you turn on logging in CompanionLink and repeat that test? I would lie to get the behavior documented.
To turn on logging
1. Open COmpanionLink Setup on your PC Desktop
2. Press "CTRL"+"SHIFT"+"L"
You should see a dialog that indicates logging is turned on.
Repeat the tests. I will send you a private message with instructions on how to get the log file to me.

Hook
10-05-2011, 09:22 AM
I just ran into the same thing. It has been awhile since I added all day events on the phone, the ones I have had for awhile were all from Outlook.

This seems to be a very reliable and predictable phenomenon having run a bunch of tests.

Add all day even (one day or spanning several days) on the phone. Sync with Outlook 2010. They are changed to Coordinated Universal Time with the start (whether one day or the first day of an event spanning several days) moved to 8pm the previous day. If you fix and re-sync, everything is fine. This only happens with all day events created in Deja Office on the phone. Events created in Outlook are fine.

Edit: I have not yet seen any signs of appointments deleted in Outlook after correcting them reappearing on the phone.

raroberts
10-29-2011, 01:27 PM
From another post, it appeared this problem was fixed in 1.12.3 beta, but I still have a problem. I have an all day event I moved to a new day within outlook. After I do an sync, the all day event changes time zone to "Coordinated Universal Time" and it now spans two days. It also changed the date back to the date I had it on before I changed it within outlook.

rscinc
10-29-2011, 03:29 PM
I am having the same problem. Droid Bionic, DJO 1.12.3, CL 5.0 build 5002. I set an all day event in DJO and after the sync, Outlook 2010 shows a two day event (5PM day one to 12AM day two) Outlook is "Arizona" time and DJO is "Mountain". Also if I start a new DJO all day event in this manner: +, enter subject, press the "From" date, press date, select date, press "All day" then ok, the event date in the main calendar add page is one day less than chosen. If I select the date, then press Ok and select "All day" from the main calender page, the date stays as selected.

noisemaker
11-28-2011, 09:20 AM
I am having the same problem. Droid Bionic, DJO 1.12.3, CL 5.0 build 5002. I set an all day event in DJO and after the sync, Outlook 2010 shows a two day event (5PM day one to 12AM day two) Outlook is "Arizona" time and DJO is "Mountain". Also if I start a new DJO all day event in this manner: +, enter subject, press the "From" date, press date, select date, press "All day" then ok, the event date in the main calendar add page is one day less than chosen. If I select the date, then press Ok and select "All day" from the main calender page, the date stays as selected.

Add me to the list. Is there a fix? I have removed and reloaded Holidays in Outlook 2010 three times now, and it's getting tiresome. I am also on a Droid Bionic Android 2.3.4 with DejaOffice 1.12.1 and CompanionLink 5.0 5002. Thanks. -- Roy

Thomas
11-29-2011, 08:05 AM
Add me to the list. Is there a fix? I have removed and reloaded Holidays in Outlook 2010 three times now, and it's getting tiresome. I am also on a Droid Bionic Android 2.3.4 with DejaOffice 1.12.1 and CompanionLink 5.0 5002. Thanks. -- Roy

Noisemaker,

I would update to 5004 immediately and to 1.12.4. 5002 was an early release for CL 5.0. Both CompanionLink and DejaOffice have been reved recently to work together better.

Update your SW on both Sides.
Check your Outlook data and confirm it is correct
Do a Purge and Reload Sync after you have confirmed your Outlook data is correct.

If you are still having trouble with the Holiday Calendar, or anything else, let me know right away.