View Full Version : DejaOffice is not responsive to Companionlink even though phone is on wifi

01-07-2013, 09:10 AM

We have a new iphone 5 and installed DejaOffice (version 1.3.8). Companionlink (5.0 b.5048) is configured for wifi sync, as is dejaoffice.

Initial sync setup worked fine at home, no issues.

When we brought the phone into work, we went into Companionlink and set the IP address correctly, but it fails to sync.

We verified that the web server on port 8090 is running. Oddly, verifying via only worked on Firefox, and failed on IE and Chrome. (We did not test this at home, so aren't sure if this is just a browser incompatibility).
Output is:
<html> <body style="background-color: rgb(220, 220, 220); color: rgb(0, 0, 0);">DejaOffice Server is running.</body></html>

We are able to ping the IP number of the phone, and confirmed that it is accessible; we also confirmed that it was registered on our wireless router using the same IP number.

I put companionlink into debug mode (Ctrl-Shift-U) and see that the log shows:
<352> (2013-01-07 12:01:50) [dates] Time Right Now 2013-01-07 12:01:50
<353> (2013-01-07 12:01:50) [Apple device] Command=
<354> (2013-01-07 12:01:50) [Apple device] Post=&build=5048
<355> (2013-01-07 12:01:59) [ClxInet 885] Waiting for Response...
<356> (2013-01-07 12:02:01) [ClxSyncStatus 251] ClxAbortProcess() - ClxInet timeout error
<357> (2013-01-07 12:02:01) [ClxInet 918] ClxGetInetString() returning early - ClxAbortProcess is TRUE
<358> (2013-01-07 12:02:01) [ClxWifi 1544] GetInetString() result: ClxErr: Unable to connect to remote device.
<359> (2013-01-07 12:02:01) [ClxWifi 1552] m_bSuppressInternetErrorMessages = FALSE
<360> (2013-01-07 12:02:01) [ClxUpd 518] ClxMessageBox: "Unable to connect to DejaOffice. Verify your IP address in CompanionLink."
<361> (2013-01-07 12:02:03) [ClxWifi 961] Login result:
<362> (2013-01-07 12:02:03) [ClxWifi 976] AppOpen() returning FALSE - Login failed

We already tried killing the dejaoffice application and restarted the phone.

Any suggestions on how to troubleshoot this further?