PDA

View Full Version : Local WiFi Sync / CL 7 - several repeating events disappeared...



tbessie
09-26-2015, 02:23 PM
I upgraded to CL 7 last week. I did a one-way sync, Outlook -> Android (with wipe phone first). Then I did a 2-way sync.

I just noticed that at least a few repeating events disappeared from both Outlook and Android. Several older/complete repeating events disappeared, and a current every-other-Monday repeating event disappeared as well. I have no idea why it was deleted, as it was an ongoing, current repeating event. But all trace of it has disappeared from phone and Outlook.

I would love it if I could count on DejaOffice/CompanionLink completely, but this kind of thing has happened on and off during my use of CompanionLink over the years, and makes it a source of continual worry for me. There's nothing as good as it, but when it does things like this, I wonder... "how many other things got lost?"

:-(

- Tim

tbessie
09-26-2015, 07:25 PM
I just noticed that it is also duplicating other repeating events.

This sucks.

- Tim

tbessie
09-26-2015, 07:30 PM
Aaaaand... after deleting one of the duplicates, ALL are deleted at next sync.

You guys really need to get your acts together regarding repeating event sync between Outlook and Android. This has happened on and off for YEARS now.

- Tim

tbessie
09-26-2015, 07:59 PM
I also see that a new Category I created in DejaOffice isn't syncing with Outlook. It says "Not in master category list" in outlook.
What's going on there?

- Tim

DJOCTO
09-27-2015, 11:15 AM
Tim, check on the phone whether it is bouncing things to the Google Calendar account. This will cause the problems you mention with recurrings. Basically the wipe cleans the phone, but they bounce back from Google.

I recommend NOT using wipe. It's not just Google. Verizon backup, and iCloud (for iOS device) does the same thing.

Hook
09-27-2015, 11:28 AM
This is really strange. I have never used wifi sync much, but I wouldn't expect it to have unique problems. However, using direct USB (both types) and Deja Cloud, I have never seen any of these problems crop up past my initial couple of weeks of taming CL-DJO back several years ago. Just for fun, I created a new category (haven't in a long while) on the phone and it synced fine.

Then again, you may have much greater complexity than I have (a mere 400 calendar items), so maybe that is where things break down and my uses don't provide enough of a stress test.

EDIT: Opps, DJOCTO slipped in while I was composing. ;)

tbessie
09-27-2015, 12:37 PM
Tim, check on the phone whether it is bouncing things to the Google Calendar account. This will cause the problems you mention with recurrings. Basically the wipe cleans the phone, but they bounce back from Google.

I recommend NOT using wipe. It's not just Google. Verizon backup, and iCloud (for iOS device) does the same thing.

I'm pretty sure I don't have anything in the basic PIM functions that connects with Google services.

Always possible I missed something, however; is it a DejaOffice setting or an Android setting? I never sync the Calendar with any Google service, that's for sure.

- Tim

tbessie
09-27-2015, 12:38 PM
This is really strange. I have never used wifi sync much, but I wouldn't expect it to have unique problems. However, using direct USB (both types) and Deja Cloud, I have never seen any of these problems crop up past my initial couple of weeks of taming CL-DJO back several years ago. Just for fun, I created a new category (haven't in a long while) on the phone and it synced fine.

Then again, you may have much greater complexity than I have (a mere 400 calendar items), so maybe that is where things break down and my uses don't provide enough of a stress test.

EDIT: Opps, DJOCTO slipped in while I was composing. ;)

I have 300 or so contacts and many Calendar items - not sure how many. When I first did a wipe/push, I synced my entire Calendar's content (going back 15 years). After that I only sync 90 days.

Not sure why I have seen these issues so often; I'm not doing anything that unusual. Most of the problems have happened with repeating events, in any case, of which I have many.

- Tim

DJOCTO
10-01-2015, 08:06 AM
Repeating events by themselves are not a problem.

The worst-case data scenario is a repeated event with many exceptions. Each exception is a link added to a chain. So when the exception is made, it adds an event to the original repeating pattern. If there are many exceptions, it becomes a long chain. If anything gets corrupt for any link, the remainder of the chain gets lost.

So if you have a lot of chains, then you will see problems in them. One good way to get around this is to restart the repeating event periodically. If you keep the exception chains under 50 links (50 exceptions) they should be pretty easy to handle.

tbessie
10-02-2015, 12:29 PM
Repeating events by themselves are not a problem.

The worst-case data scenario is a repeated event with many exceptions. Each exception is a link added to a chain. So when the exception is made, it adds an event to the original repeating pattern. If there are many exceptions, it becomes a long chain. If anything gets corrupt for any link, the remainder of the chain gets lost.

So if you have a lot of chains, then you will see problems in them. One good way to get around this is to restart the repeating event periodically. If you keep the exception chains under 50 links (50 exceptions) they should be pretty easy to handle.

I have a few exceptions, but mostly not. I'll look into your suggestion in any case. :-)

- Tim

DJOCTO
10-04-2015, 10:20 AM
Tim, I have to apologize. That wasn't my best answer.

Now it's happened to me! I'm not sure if it's the same thing, because I use DejaCloud sync. I need to wait until Tues to find out because my developer is away tomorrow. Grrr...

Aside from me and you, we don't have other reports of this. So I'm thinking this is a 1-off problem. I'll know more on Tues.

DJOCTO
10-06-2015, 11:06 AM
Tim,

Try this:

Go to DejaOffice, Settings, DejaCalendar settings. Select the 2nd to the last item "Rebuild Calendar Display". This will restore some hidden entries.

tbessie
10-21-2015, 11:53 PM
Tim,

Try this:

Go to DejaOffice, Settings, DejaCalendar settings. Select the 2nd to the last item "Rebuild Calendar Display". This will restore some hidden entries.

Sorry for the delay - rebuilding calendar display didn't fix it the last few times it's happened (including the one I reported). I had to remove all offending repeating entries on both platforms (Outlook and Android), do a full "re-read both" sync, add the entries again, do another full "re-read both" sync.

- Tim

DJOCTO
10-22-2015, 08:09 AM
Ugh sorry.

tbessie
10-22-2015, 10:18 AM
Oh well. :-/