PDA

View Full Version : Push Sync Not Working



Eagle 3
10-11-2017, 07:21 PM
When I make a change in Outlook, Push Sync in not working on my Note 8 with DejaOffice 4.3.7 build 1010. DejaCloud Sync. I have to do a manual sync to get it to update. Help.

DJOCTO
10-11-2017, 07:28 PM
Working both ways for me just now, so the server is up and running.

It doesn't need XMPP from OL to the Server. It looks for one of two things;

1. Check that the CL Outlook Add-In is running. Outlook may have turned it off. This is the first signal.

2. Within 5 minutes, CL does a "manual checK" of the OL folder. So look for any issues with that folder. For instance, setting your system clock back or forward can affect folder last-mod time.

That's all I can think of tonight.

Eagle 3
10-11-2017, 08:35 PM
It syncs to CRM just fine. I checked that before checking the phone. So the problem is just from DejaCloud to the phone, Sorry, I should have mentioned that in the OP.

DJOCTO
10-13-2017, 03:42 PM
DejaCloud to phone uses an XMPP Connection on a really strange port; I think 5222. This is an "aol messenger" style connection. So it's readily blocked by firewalls and stuff.

However, the phone checks in periodically, but it's just not as fast.

Did you see in DejaOffice CRM Live, there is a button to ping the phone? It's good for testing. At least I think I saw it there.

In any case, rebooting your phone usually re-establishes the connection. Our XMPP server has been doing well, last downtime was in Feb or so. It's mostly up except for late night friday nights which is our maintenance window.

Eagle 3
11-08-2017, 09:16 AM
DejaCloud to phone uses an XMPP Connection on a really strange port; I think 5222. This is an "aol messenger" style connection. So it's readily blocked by firewalls and stuff.

However, the phone checks in periodically, but it's just not as fast.

Did you see in DejaOffice CRM Live, there is a button to ping the phone? It's good for testing. At least I think I saw it there.

In any case, rebooting your phone usually re-establishes the connection. Our XMPP server has been doing well, last downtime was in Feb or so. It's mostly up except for late night friday nights which is our maintenance window.

I couldn't find the ping button on CRM Live.

I've tried many things trying to get this to work, including rebooting, uninstalling DejaOffice including deleting the clusb folder and reinstalling.

When the push sync doesn't work and I sync manually, the push sync will work for a little while, maybe 30 minutes or several hours. There is no consistency. Since no one else is having this problem and it's just my Note 8, there must be something on my phone that is causing the problem. I have not idea what it could be.

Push sync worked fine on my Note 4.

DJOCTO
11-10-2017, 07:35 AM
On the new phone, check the Power Optimize settings. Samsung has this new thing to "optimize" apps, and what they mean is that it turns off the background check process.