PDA

View Full Version : DJO 4.3.7 Mobile number starting 0 deleted issue



laurentdjo
12-24-2017, 11:22 AM
Hi,

A new bug with the last DJO version that deletes numbers beginning with 0.
Thus, OK for +33 6 34 07 00 00 and the number is deleted of I enter 06 34 07 00 00 !

Here the log:
2330) 12-24 19:44:37 BaseEditActivity: saveAutocompleteValues() added 0 entries
2331) 12-24 19:44:37 ClSqlDatabase: updateAttachmentsForRecord() added 0, updated 0, deleted 0
2332) 12-24 19:44:37 ClSqlDatabase: Field Changed: phoneValue1 from '+33 6 34 07 00 00' to ''
2333) 12-24 19:44:37 ClSqlDatabase: isRecordChanged() changed fields: phoneValue1

An empty value instead of 06 34 07 00 00.

The DJO application has became just unusable !!!

Regards.

DJOCTO
12-26-2017, 07:36 AM
Laurent, if it is really the DJO version then you can download one back

https://www.dejaoffice.com/androidapp/releasenotes.html

DejaOffice v4.3.6 (1002) (7/24/17)
http://www.dejaoffice.com/androidapp/oldbuilds/DejaOffice4_3_6_1002.apk

There is a change in the recent build for phone formatting. It uses your Device formatting for it. I'll investigate to see if there is a setting for this. In the mean time, just go one version back until we can get this fixed.

Is anyone else seeing issues with phone formatting?

laurentdjo
12-26-2017, 08:00 AM
Hi,

Thank you very much.

I can't install DejaOffice4_3_6_1002.apk because the system says this package seems corrupted...

Regards.

Eagle 3
12-26-2017, 08:20 AM
I'm using v4.3.7 (1018) and do not have this problem. I live in Thailand and all mobile phone numbers begin with 0.

laurentdjo
12-26-2017, 08:46 AM
But you have an old Android... I use Android 7.1.1 ! Rgds.

Eagle 3
12-26-2017, 09:42 AM
Sorry, I forgot to update my signature. It's updated now, I'm on 7.1.1.

laurentdjo
12-26-2017, 02:13 PM
Well, it doesn't work with my SGN8 perhaps because it is a French localisation as suggested by DJOCTO with formatting API... I cannot go back to test the previous version that is said as corrupted by Android OS... Rgds.

Cecil
12-26-2017, 02:47 PM
I had a problem once with a corrupted Dejaoffice. You have 2 options to try, uninstall and reinstall, or rename the CLUSB folder. The first option should pick up your existing database but if that is corrupt you will need to go with option 2 and pickup the data from a sync. At reinstall you can either try the current version or an earlier version.

laurentdjo
12-27-2017, 03:04 AM
Hi Cecil, this is not my installed DJO that is corrupted, but the APK to download so as to go back to previous version. I already refreshed the DB because on a brand new Note 8. DJOCTO seems to know about a defect of the new version... Rgds.

treofan
12-27-2017, 10:22 AM
I have the same problem: DJO 4.3.7 deleting phone numbers starting with 0

treofan

Samsung Galaxy A5, Android 7, USB-Sync, PC Windows 7 pro 64 bit

laurentdjo
12-27-2017, 01:47 PM
Thks Treofan :cool:

laurentdjo
12-28-2017, 02:37 AM
Dear DJOCTO,

I'm not able to install your package because Note 8 says it is corrupted in some ways...

DejaOffice v4.3.6 (1002) (7/24/17)
http://www.dejaoffice.com/androidapp...4_3_6_1002.apk

Regards.

DJOCTO
01-08-2018, 04:00 PM
Laurent,

My programmer thinks he fixed it. Please try the beta:

https://www.dejaoffice.com/androidapp/inhouse/DejaOffice.apk

From the programmer:
The latest inhouse DJOA (4.3.8 1019) has a fix for this.
The issue is NR for me, but could be based on manufacturer/carrier/old version issue. Now, if the formatting gives back a blank string, it will use the unformatted number instead.

laurentdjo
01-09-2018, 11:09 AM
Thanks DJOCTO,

Firstly, I have a well-known and modern mobile: Samsung Galaxy Note 8. Not exotic at all...

I have tried the DejaOffice.apk without success with the screenshot.

Something is going wrong with dev APK versus installation coming from Google Play Store !? On the contrary, I'm able to install other APK on my phone: only DJO APKs here have installation issues...

Regards.

265

laurentdjo
01-23-2018, 02:47 PM
Hi DJOCTO, what happens to my case ? And it's so weird that the standard DJO update through Play Store works well but that your APKs fails !? It gets even weirder when knowing I have no problems with APKs from F-Droid store... Regards.

DJOCTO
01-25-2018, 08:05 AM
Laurent, I think it's just security software on your phone that is blocking the non-app store version.

I think our fix is verified now. I'll see if we can push it to the Play Store.

Edit: This is now in the Play Store. Please tell me if this is fixed in this update. Thanks.

laurentdjo
01-27-2018, 03:02 PM
Hi,

The fix is OK.

But this is not just security software that blocks the install, because all APK I have out of the Play Store can be installed, but yours !?

Regards.