View Full Version : Cloud sync doesn't work unless synced manually from phone

Paul White
02-12-2018, 04:51 PM
It refuses to sync with the Cloud unless I manually initiate the sync from my phone. This failure cost me a $1000 job because the appointment didn't transfer to my phone and I missed it! Yes, Push Sync is enabled. Disgusted!:mad:

02-12-2018, 05:07 PM
Paul, I'm sorry to hear that you missed the job.

Push sync is down, and has been since we switched servers last week. Our server is more secure but somehow that security is interfering with the push process.

It is a top priority for this to work and we spent all day on it.

Although Push sync is down, as far as i know it should be polling on the backup timer which I think is 10 minutes. I'll check on that.

Paul White
02-12-2018, 05:12 PM
You should have notified users that there was a problem!! And, have you never heard of testing BEFORE switching servers! Please explain "polling on the backup timer.

02-13-2018, 12:52 PM
You are right, Paul. Usually I even post a note here.

The issue is that although Sync is working fine, the XMPP message for the "push" has not worked since we switched servers.

We did test the new server and validated XMPP on it. However, we find the server under full load operates differently than when we tested. So we have been unable to pull the XMPP portion up to full load.

We have validated that the backup timer for PC is working - 5 minutes.

We validated that on the iPhone, the backup timer works - 15 minutes.

On Android, when you start DejaOffice or make a change in DejaOffice, both will initiate a sync. However, in some cases the backup timer was not working if Android OS had shut down DejaOffice. This is done Android OS is sensitive to CPU usage for non-focus apps.

For today, we create a patched and pushed to the Play Store. If you update DejaOffice, it has a 10-minute backup timer that will force a sync even when DejaOffice is not active.

It has seemed like we are always on the verge of getting XMPP fixed, and then we find our fix is not working.

Right now, we think XMPP will be fully working in just another hour or two. We have two people working on it now, and they have high hopes that we are almost all set.

02-15-2018, 10:42 AM
As of today Feb 15, XMPP is fully running.

Our system is (supposed to be) built to run without it. What XMPP does for us is; with Push Sync, it provides the extra "push" reducing sync times from 5 minutes to about 2 seconds. So when you make a change on your phone, once phone sync completes the PC will sync.

We had to change servers sometime in this quarter, because our old server had reached an OS "End-of-life" (Ubuntu 12) and would no longer get security updates. We changed servers at 5am Pacific Time on Feb 6. From that time until today, XMPP has been up and down, but not dependable. Paul's message above is from Sunday Feb 12, about 5 days into it, and on that day I know that XMPP was not running.

We had tried several options for it. But this week I got a different web service guy and we got ejabberd and erlang back up and running. We found that our XMPP library on the server was no longer up to the task. So we rewrote the server side to bypass the non-working library. Finally today, we resolved an issue where the data stream was getting an unintended \n character.

All looks good today, and the server load is good, sync speeds appear to be fast. Hopefully we can run like this for years to come.
When we changed servers on Feb 6