Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 57

Thread: Alarm (reminders) are not working!

  1. #41
    Junior Member
    Join Date
    Sep 2016
    Posts
    7
    I solved this issue by deactivating my android phone's "downtime" and "flip to save power" features in settings.

    I am a Blackberry Priv user. The Blackberry Priv is an android phone. Last week I began having problems with DejaOffice alarms not going-off too. My DejaOffice is not synced with my phone's local calendar (only my DejaOffice contacts are synced with my local contacts per instructions received from DejaOffice when I installed the app). DejaOffice was working fine and then suddenly, it would only start working each day after I opened DejaOffice calendar that day. After doing all the things previous persons have posted they did in this thread to date without success, I remembered that last week I activated my android phone's downtime feature (in settings) so that my phone would effectively go to sleep everyday from 11pm to 7:30am the next day. So, I deactivated my phone's downtime feature again and DejaOffice began working perfectly again (sounding alarms without me having to open the DejaOffice calendar up each day). To test my theory, I reactivated downtime and sure enough, DejaOffice stopped working. I then deactivated downtime again and again DejaOffice started working without any problems.

    I think the problem is that DejaOffice is a 3rd party app on your phone (unlike the phone's local calendar, which is installed by the manufacturer) that your phone does not check during and after downtime. To explain, I think when you activate the downtime feature, the phone closes all apps (local and 3rd party) when downtime begins. During downtime, the phone checks local apps (like local calendar). However, the phone does not check 3rd party apps (like DejaOffice) when downtime begins and does not reopen them after downtime ends. It takes an external event (for example, receiving an email or physically opening DejaOffice calendar) to restart 3rd party apps again. And, selecting that you want your phone to check your calendared events/alarms during downtime does not resolve this DejaOffice problem because the phone will only check your local calendar, and not your DejaOffice calendar, a 3rd party app. So, if your local calendar is blank (because it was never synced with DejaOffice calendar), your phone thinks there's no events scheduled and, therefore, no alarms to sound-off.

    For those of you still having issues with DejaOffice alarms not working, check to make sure you don't have your phone (android or iphone) set to activate downtime or some similar feature like "flip to save power" (see separate posted explanation below). If it is, deactivate those features.

    I don't know if these actions will help everyone resolve this problem, but they worked for me and, hopefully, they resolve this issue for some of you.
    Last edited by BBUser12; 09-30-2016 at 06:35 AM.

  2. #42
    Senior Member
    Join Date
    Oct 2011
    Posts
    445
    There is an ongoing problem with Android 6 phones. Android 6 has an emphasis on saving battery life. It goes into Doze mode when the phone is stationary and until the alarm system rewrite is completed DJO cannot wake phone from Doze mode.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1131) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1131)
    WiFiSync
    Syncs to Android Contacts App only

  3. #43
    Member
    Join Date
    Apr 2015
    Posts
    48
    A few possible reasons for errors (alarms/reminders not working) could be eliminated if DejaOffice would register itself in the op.system as alarm clock.

  4. #44
    Junior Member
    Join Date
    Sep 2016
    Posts
    7
    In addition to the downtime function that I mentioned above, there's another sleep-related function that closes DejaOffice (and other 3rd party apps) that I want to point out: the "flip to save power" function under the advanced interactions tab in settings. "Flip to save power" causes the phone to go to sleep (like "downtime") when placed facedown. So, in addition to deactivating the "downtime" feature, make sure that "flip to save power" is turned off.

    Again, I don't know if my posts will help everyone resolve this problem, but these actions worked for me and, hopefully, they resolve this issue for some of you.
    Last edited by BBUser12; 09-22-2016 at 07:47 AM.

  5. #45
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,299
    I'm glad to hear that worked for you.

  6. #46
    Member
    Join Date
    Apr 2015
    Posts
    48
    @DJOCTO
    Is it possible for DejaOffice to register itself in the Android operating system as alarm clock in order to eliminate these kind of issues?

  7. #47
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,299
    Arpad, it is not entirely clear what needs to be done. Currently we ARE registered as an "alarm clock" with the notifications.

    Our working theory is that we need to rewrite our system to the new Marshmallow style notifications, which could break the system for anyone using an older system. It's not just the notification, we need to revise the manifest, so this affects all Android OS Services; Wi-Fi, Contacts, Voice. In all, the update will impact about 20 system services, and likely break at least a few of them as we bring the code forward to the new methods.

    So for a small thing that is easily worked around, there will be much disruption when we roll the fix.

  8. #48
    Senior Member
    Join Date
    Nov 2011
    Posts
    146
    Quote Originally Posted by DJOCTO View Post
    So for a small thing that is easily worked around, there will be much disruption when we roll the fix.
    How does that work-around work for Android 6 devices? Doze is mandated for android 6 and up and cannot be normally disabled. On a rooted system I did manage to configure the doze-delay to 24hrs but is there a work-around which works without having to root the device?
    -Frans

    Samsung Galaxy s7, stock rom 8,0, not-rooted
    DJO 4.4.21 (1140) - generally up-to-date normal release channel via Playstore , CompanionLink 8030
    Outlook 2016 (32bit), sync via DejaCloud (native sync Contacts only)

  9. #49
    Senior Member
    Join Date
    Oct 2011
    Posts
    445
    AFAIK

    There are two ways to stop your phone going into Doze.

    I think Doze mode is enabled when the phone is stationary for more than 30 minutes.

    Keep the phone moving , if it is in your pocket during normal activities this stops the phone Dozing.

    Put your phone on charge while it is stationary for any length of time. Doze mode is inactive when phone is on charge.
    Last edited by Cecil; 10-25-2016 at 11:50 AM.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1131) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1131)
    WiFiSync
    Syncs to Android Contacts App only

  10. #50
    Senior Member
    Join Date
    Oct 2011
    Posts
    445
    Marshmallow (Android 6) Problem fixed?


    I always try out the in-house beta builds of DJO. I am now running 939 and noticed that the DJO icon was not being properly rendered implying that changes had been made to the notification system. This morning the 8.00 alarm sounded correctly, the phone had been stationary for 11 hours so should have been in doze mode.
    Last edited by Cecil; 11-03-2016 at 03:07 AM.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1131) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1131)
    WiFiSync
    Syncs to Android Contacts App only

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •