Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Telephone Format Changing in DejaContacts

  1. #1
    Junior Member
    Join Date
    Jul 2011
    Posts
    6

    Telephone Format Changing in DejaContacts

    Hi

    New to DejaOffice and I like the sync from Outlook 2010 to my Acer A500 tablet.

    However, in Outlook 2010 my phone numbers are in the following format:

    0XXXXXXXXXX (UK)

    When I send my contacts from Outlook to DejaContacts, they are in this format. However, if I edit a contact (even if it isn't a phone number change) in DejaContact, all the phone numbers then change to the following format:

    0XX-XXX-XXXXX

    I tried the same with a Dutch number where the format in my Outlook is:

    +31 XXXXXXXXX

    and it remained the same.

    Does this mean that I should change all of my UK phone numbers to +44 XXXXXXXXXX for the sync to work correctly?

    Everything else works great and I am seriously considering paying for the full program, but I would like an answer to the above before I do. If I have to change the phone format to sync with my Acer Tablet, it will then change everything as I sync my Oulook to my Blackberry phone, and this has no problems whatsoever with the phone formats.

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Posts
    166
    Hello Acerman,

    No, you don't have to change the UK phone numbers.

    I had the same problem and it is just a setting you have to change.
    The number setting you are getting is a US format.
    We, in Europe, use different formats.

    In CompanionLink you have to go to < advanced settings>, <phone format>
    You have to uncheck <use US formatting>
    And check <sync all country codes>
    This should solve it.
    All my numbers are in Dutch format and are synchronising the same format to my android.

    NOTE:

    If your contact formats are still corect in Outlook but have changed in Dejacontacts you have to synchronise with the following setting in CompanionLink.
    1. Outlook settings (I use Palmdesktop)
    2. applications
    3. check contacts
    4. set <Outlook to android>
    5. check purge and reload (this will make sure nothing changes in Outlook and everything is wiped from the android and replaced with the data from outlook)
    6. Outlook is primary
    7. set <Outlook changes are kept>

    Good luck and I hope this helps.

    Lexie

    ps if you synchronise your calendar as well, makes sure that you change in <advanced settings> the amount of days you want to sync.
    The default is set to 90 days.
    I have synchronised more than 7 years and have it set to 5000 to be sure (nice round figure)
    Last edited by Lexie; 07-09-2011 at 12:39 PM.

  3. #3
    Junior Member
    Join Date
    Jul 2011
    Posts
    6
    Hi Lexie

    Thanks for your info. I did all as you suggested, but I still have the same problem. If I edit a contact in DejaContacts, even if it isn't the phone number, as soon as I save the contact the phone number goes to XXX-XXX-XXXXX.

    Any thoughts?

    Acerman

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Posts
    166
    Yeah, it must be the settings in Cl since you can't change the settings for this in DJO. As far as I know.
    I have added a new contact with the number 0031123456789 and saved it. It was saved exactly like that.
    I did do it with 0612345678 as well and saved that and it was saved like that also.

    Did you do a purge and reload after you changed the setting in CL?
    Because that could maybe be the difference.

    I have made screenshots of the settings to be sure you did as I did.
    Maybe my explanation wasn't clear...me being Dutch and using English

    testinstelling.JPGtestinstelling 2.JPG

    I hope this helps, or else you have to wait until tomorrow for the DJO team to help you.
    This is as far as my knowledge goes.

    Regards,
    Lexie
    Last edited by Lexie; 07-10-2011 at 11:49 AM.

  5. #5
    Junior Member
    Join Date
    Jul 2011
    Posts
    6
    Lexie

    Sorry for the delay in replying, been away for a few days. Your english is excellent and I understood every word (having worked in Nord Holland I know the Dutch speak very good English, unlike me and Nederlands )

    I note on one of your screens that you ticked the box "Format phone text for Windows Mobile Devices" which I did not have ticked. The next time I sync I will click that box as well and see what happens.

    Dank u wel.

    Grtz

    Acerman

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Posts
    166
    Acerman,

    Graag gedaan

    I don't know if that makes the difference, but it is the way my settings are and for me it works.

    I hope it does for you as well!

    Regards,
    Lexie

  7. #7
    Junior Member
    Join Date
    Jul 2011
    Posts
    6
    Hi Lexie

    Well, tried a few different settings and every time I edit a record on my Acer Tablet, the phone number automatically changes from the format it is in to the US format. Even if I don't edit the phone numbers, as soon as the amended record is saved the phone format changes. Most annoying and I cannot see a way to stop this. Perhaps someone from DJO can come up with an explanation.

    Acerman

  8. #8
    Senior Member
    Join Date
    May 2011
    Posts
    518
    If you like all the phone numbers untouched - as I do - I suggest to untick all the options and clear the country code field as well.
    The country code field will re-fill itself with a 1 if you reopen the dialog, which is a bug IMHO. However, if it is empty when you click OK, it works as designed.

    Copied from a thread answered by Thomas - you can also find this very detailled if you search the Support section of the Companionlink webpage:

    Regarding international Phone dialing codes please use this article to configure COmpanionLink:
    [AB42741] The Phone Format options allow you to customize the way that phone numbers synchronize between your contact manager and your handheld device. You can access these options in CompanionLink Settings/Advanced Settings/Phone Format tab.

    Here is a description of each option:

    Use US formatting for phone numbers:
    If this option is checked, any 10-digit phone numbers in your contact manager will synchronize to your handheld device using the US phone number format (###)###-####.

    Automatically include extensions:
    If this option is checked, telephone extensions will be synchronized along with phone numbers. Extensions will be denoted by the symbol specified in the "Symbol to use for extensions" field (see below).

    Clear leading zero on phone numbers:
    In many phone numbers outside North America, a "0" digit immediately following the country code is used as a national direct dialing prefix. In some contexts it may be desirable to remove this "leading 0" when synchronizing to your handheld device. This can be facilitated by checking the "Clear leading zero on phone numbers" option.

    If "Clear leading zero on phone numbers" is checked, any phone number in your contact manager that includes a leading "0" AND has a country code that does not match your local country code (see below) will synchronize to your handheld device with the leading "0" omitted. Conversely, any phone number in your contact manager that includes a leading "0" AND has a country code that matches your local country code will synchronize to your handheld device with the leading "0" included.

    Example without matching local country code:
    Phone number in contact manager: +44 03141592653
    Local Country code: 33
    Synchronizes to handheld device as: +44 3141592653

    Example with matching local country code:
    Phone number in contact manager: +44 03141592653

    Local Country code: 44
    Synchronizes to handheld device as: 03141592653
    (NOTE: In this example, the leading "0" is preserved and the local country code is removed. See "Local Country Code" below for more information).

    Symbol to use for extensions:
    If the "Automatically include extensions" option is checked, any telephone extensions synchronized to your handheld device will be denoted by the symbol specified here.

    Local Country Code:
    Any phone number in your contact manager with a country code that matches the local country code specified in this field will be synchronized to your handheld device with the country code omitted. Conversely, any phone number in your contact manager with a country code that does not match the local country code specified in this field will be synchronized to your handheld device with the country code included.

    Example without matching local country code:
    Phone number in contact manager: +49 66 2606 8
    Local Country code: 31
    Synchronizes to handheld device as: +49 66 2606 8

    Example with matching local country code:
    Phone number in contact manager: +49 66 2606 8
    Local Country code: 49
    Synchronizes to handheld device as: 66 2606 8

    Sync All Country Codes:
    Selecting this option disables the local country code and does not allow you enter a local country code. This function replaces the need to put 9999 for local country code.

    HTH
    McL

  9. #9
    Junior Member
    Join Date
    Jul 2011
    Posts
    6
    Hi McLion

    Many thanks for your reply. I think I may have confused the issue somewhere as the problem isn't so much with CompanionLink but with DejaOffice Contacts on my Acer A500.

    I can transfer the numbers in the format I wish to my Acer A500 from my Outlook 2010 on my computer. I get 0xxxxxxxxxx from Outlook to appear as 0xxxxxxxxxx in DejaOffice Contacts.

    However, if I am away with my tablet and I make a change to one of my contacts (or even add a contact) in DejaOffice Contacts, the phone number format changes from 0xxxxxxxxxx to 0xx-xxx-xxxxxx, even if I haven't amended the telephone number! It appears to be a DejaOffice Contact bug rather than a CompanionLink bug. I cannot find anywhere in DejaOffice Setup where to state what language I want to use, be it UK English or International English. I appear to be stuck to using US English formats.

    Maybe someone from DejaOffice can help out with a solution here, please?

    TVM

    Acerman

  10. #10
    DejaOffice Team Ben's Avatar
    Join Date
    Jul 2010
    Posts
    160
    Acerman - Hmmm. We're calling an Android function to detect/format the phone numbers, so this looks like it's actually a bug in Android. I think what we'll do to work around it is to just disable formatting for non-US numbers, so that it leaves the number in whatever format you entered it. I'll try to get this added to the next beta release.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •