Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: DO syncs to native Contacta app, but can't be seen

  1. #1
    Junior Member
    Join Date
    Jul 2012
    Posts
    7

    DO syncs to native Contacta app, but can't be seen

    I've been lurking the Forums for a few days and really appreciate the tips and advice shared by everyone. After Thomas spend a generous amount of time on the phone with me to get my PC applications to sync properly, he suggested that I post this question since it's more phone-related than DO/Companion Link related. The phone user manual does not help. It's an Incredible 4G, using Android 4.0 and HTC Sense 4.0. I'm using CompanionLink Express 5.0.

    Under Sync Settings I've checked "Sync with Android Contacts App." After syncing with Act! 2007, my contacts can be seen in DejaContacts and do, indeed, get pulled into caller ID -- which leads us to believe that they are somehow synced with the Native Android People/Contact App. However, when i open the People App, I am the only contact listed. I've used the "Phonebook" pull-down in the Android app, and it lists the following as options: SIM (0) - checked; Phone (0) - checked; an Exchange Active Sync account (0) - not checked; and a gmail address (0) - not checked. No people are in any of these accounts (thus the zeros noted).

    Neither Exchange nor Gmail are my primary account, and my primary account - the Contact Account selected in DO Sync Settings - is not listed. I can't find any other setting that might affect what is seen in the Android contacts. I do subcontracting for a variety of companies, one of which uses the Outlook Exchange Server. Shifting my primary account to the Exchange or gmail account is not an acceptable option.

    Any ideas on how to get synced contacts to appear in the Android app? Are there any advantages or disadvantages to not having them be seen?

    Thanks very much!

  2. #2
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    I would dearly love to know how you got DejaOffice to connect with caller ID and show up.

    Is it because you forced a sync with the native Android contact app (even though they're not showing up)?

    I'd really love to not have to do a bunch of different syncs and don't use Gmail so don't want to use that as a bridge.

  3. #3
    Junior Member
    Join Date
    Jul 2012
    Posts
    1
    somecat,

    I am having the exact same issue as you. I need it resolved as well. I'll let you know what I find out. Everything worked great for me under Gingerbread, but since upgrading to ICS - no love.

  4. #4
    Senior Member
    Join Date
    May 2011
    Posts
    518
    There's no need to use gmail to have that activated. In fact, it is advised to NOT sync the contact account from your phone that you use to sync to DJO to sync to anything except DJO. However, to have the phone to look up the caller ID you need to sync DJO to a phone account because android can not lookup the contact in an external database like DJO is. You set that up with the wizard or in settings of DJO, and it is a "fire and forget". You don't have to care about after it is set up, you just want to make sure the contact account of your phone you are using is empty before you activate the internal sync to not get duplicates.
    Google Pixel, Android 9.0 German, DJO 4.4.9 (1076)
    Office: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, daily
    Home: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, occasionally
    Syncing to native Android contacts (DJO account), not syncing to native Android calendar

  5. #5
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    KAT and gkittredge,

    I finally have an answer that addresses both my original question and hopefully yours, too. I also lost the caller ID function somewhere along the way, and finally have my contacts in the Android People phonebook AND caller ID working properly. Here's what worked for me:

    - In DJO Settings -> Sync Settings:
    - Select "Sync Contacts with Android." (You probably already had that.)
    - Under "Contact Account," select your gmail account. Before you protest about having your stuff in the Cloud (I certainly pushed hard on that!), you can set your gmail account to NOT sync to any Cloud-based apps. I understand that in this case it's just an account for your own "internal" communications, and a later instruction below will explain why it's needed if you want DJO contacts to appear in your Android People/Contact phonebook.

    - In Android Settings -> Accounts & Sync
    - Select your gmail account. Make sure that none of the sync options are checked.
    - When you back out one level and see your list of accounts, you can see that the gmail account sync icon is grayed out, so no syncing with our friends at Google will occur.

    - Run a CompanionLink/DJO sync. Afterwards, if your caller ID/call log or Android People (Contacts) are not showing your contact names:

    - On the DJO main screen, select "Read Android Data" by holding it for a few seconds. This button triggers a manual sync with the Android app.
    - When "Read All Data" pops up (a result of holding the button down), click on it. In theory, you shouldn't have to Read All Data again after this, unless you wipe out all of your Android data during a CL/DJO sync. From what I understand, reading and syncing with Android data is a normal part of the CL/DJO sync process, but this is a quick work-around if that part of the process has a minor breakdown.
    - At this point, my phone log was populated by appropriate contact information.

    - Open the Android People app. If you don't see your contacts, select "Phonebook" at the top of the page.
    - Select your gmail account, which should now be populated with your DJO contacts. You'll note that under Phonebook, the options you have are limited (e.g., gmail, an Exchange Acct, SIM card). I've never been able to get a Phonebook option of my own non-gmail account...which is why I could never get my contacts to show here.

    Voila! I hope this works for you.
    Many thanks to Thomas for helping me get set up to properly sync multiple PC data sources.

    somecat

  6. #6
    Senior Member
    Join Date
    May 2011
    Posts
    518
    @somecat
    Nice work, and very detailed. We should have this pinned.
    Some things to make sure:
    - Before hitting the "Read Android Data" make sure the Android app is empty, or at least does not have the same contacts as DJO
    - If you did Sync with CL before activating it, and your PC is up to date and there is nothing in the native android contact data that you want to merge, you can also check "Wipe all records in Android.." which will replace all the data on the Device with a new copy from the PC to DJO and since you activated the native sync to Android's native contact app as well.
    Google Pixel, Android 9.0 German, DJO 4.4.9 (1076)
    Office: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, daily
    Home: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, occasionally
    Syncing to native Android contacts (DJO account), not syncing to native Android calendar

  7. #7
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    Thanks, McLion - for the kind words and the additional tips. In fact, I did "Wipe all records in Android" -- and hadn't thought about that step in the above.

    That's one sync problem figured out. Now to get subsequent syncs to work properly. This has truly been a bear...much more difficult than using CL to sync to my ancient BB.

    somecat

  8. #8
    Junior Member
    Join Date
    Dec 2010
    Posts
    15
    These are great instructions. I have been looking for something like this.

    All my Android contacts had duplicates after a recent sync to Outlook and I used "Contact Remover" to delete all my contacts. I don't save any contacts in Gmail and my Outlook 2007 is my primary database.

    I followed all your steps twice and still do not have any Android Contacts or calendar events. I deleted and reinstalled DJO also. New contacts are saved to the DJO database from Outlook.

    I am posting here to see if anyone might have an idea.


    Motorola Droid Pro on Android 2.3.4
    DejaOffice version# 2.2.8
    CompanionLink build # 5032
    Data Manager App - Outlook 2007
    Sync Method with CompanionLink - USB cable with USB connection set for Charge only.
    DejaOffice Sync Settings for Contacts and Calendar. - "Sync with Android Contacts App" is checked. My Gmail account is selected.
    Last edited by rbtnt; 08-20-2012 at 12:22 AM.
    CL 7.0 0.0 Build 7016
    DJO 4.1.4 Build 915
    USB sync
    DJO sync settings: sync with Android Contacts App, sync with Android Calendar App
    Droid RAZR HD not rooted
    Android Version 4.4.2
    Outlook 2013

  9. #9
    Senior Member
    Join Date
    May 2011
    Posts
    518
    One thing to double-check: Make sure to have the gmail account active/displayed in the nativ apps and have the google sync turned off on the device.
    Google Pixel, Android 9.0 German, DJO 4.4.9 (1076)
    Office: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, daily
    Home: Win10 x64, Outlook 365 (v2016, up to date) German, CL Express 7050 --- Local WiFi sync --- manual syncing, occasionally
    Syncing to native Android contacts (DJO account), not syncing to native Android calendar

  10. #10
    Junior Member
    Join Date
    Dec 2010
    Posts
    15
    I tried it tonight and DejaOffice synced with the Android contacts. I did not make any changes from last night. This has happened before, but it has been seveal months since it has.
    CL 7.0 0.0 Build 7016
    DJO 4.1.4 Build 915
    USB sync
    DJO sync settings: sync with Android Contacts App, sync with Android Calendar App
    Droid RAZR HD not rooted
    Android Version 4.4.2
    Outlook 2013

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •