Closed Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: DJO does not delete Outlook calendar events

  1. #1
    Senior Member
    Join Date
    Jul 2010
    Posts
    389

    DJO does not delete Outlook calendar events

    Hi,

    When I delete a calendar events in DJO, this event is note deleted in my Outlook biz and even recreated in DJO, even after trying several times !?!!!

    This is not happening if I delete events from my Outlook biz or my Outlook home : the deletion on DJO is OK and on each Outlook too.

    What's happening ?

    Regards

    French / Windows XP SP3 / Outlook 2003 SP3 / CL Pro 4.0.4006 / Samsung Galaxy S / Android 2.1 / DJO 1.6.1b / param = days back 30 + sync both ways + deleted both + sync alarms + cleared records

  2. #2
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    Always bad with DJO 1.6.2 : delete DJO events ar not deleted in Outlook and recreated in DJO ! Regards.

    French / Windows XP SP3 / Outlook 2003 SP3 / CL Pro 4.0.4006 / Samsung Galaxy S / Android 2.1 / DJO 1.6.2 / Param = days back 30 + sync both ways + deleted both + sync alarms + cleared records

  3. #3
    Junior Member
    Join Date
    Aug 2010
    Posts
    5
    I am having the same problem with my HTC Droid Incredible. In the CL Setup - Outlook Settings - Applications tab, I have the Transfer Direction set to "Android to Outlook" and the Primary Database set to Android. I am under the impression that the latter setting is meant to ensure that any calendar appointments deleted on the device will be reflected in Outlook. However, when I open my Outlook calendar the appointments deleted on the device are still there and have not been deleted in Outlook.

    Please help

  4. #4
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    Thanks for your feedback that indicates this is not only a Galaxy S incident ; surely, the DJO Team will do its best to correct such a malfunction ! Regards.

  5. #5
    DejaOffice Team Ben's Avatar
    Join Date
    Jul 2010
    Posts
    156
    larentdjo and Skip-A - Both of your reports sound like modified time issues. Basically, when a record has conflicting edits (e.g. a calendar event that has been deleted in Outlook and also modified on Android), the edit with the most recent modified time is kept.

    Here are a couple of things to check that may resolve the issues for you:

    1. Make sure that Google sync is off on your Android. With Google sync on, it could be the case that Google is updating the records on Android after you have changed/deleted them on Outlook, so that the Android changes are always kept, instead of the Outlook ones.

    2. Make sure that the system time on your PC and the system time on your Android are the same.

  6. #6
    Junior Member
    Join Date
    Jun 2010
    Posts
    6
    [QUOTE=Ben;1386]larentdjo and Skip-A - Both of your reports sound like modified time issues. Basically, when a record has conflicting edits (e.g. a calendar event that has been deleted in Outlook and also modified on Android), the edit with the most recent modified time is kept.
    QUOTE]

    That's good to know, but also generates a few questions for me.

    1. Do you plan on onffering the user a choice to pick which record to keep or even creating a duplicate on both devices?

    2. Do you plan on offering a notice that the two device times are not synchronized?

    Thanks,
    -William
    Motorola Droid (Verizon - Android version 2.2 Build FRG22D)
    DJO Release v1.6.8 BETA (Paid/Registered)
    Companion Link Version 4.0 Build 4015
    Outlook 2003 (Office Pro Suite)
    XP Pro (sp3) PC

  7. #7
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    Quote Originally Posted by Ben View Post
    larentdjo and Skip-A - Both of your reports sound like modified time issues. Basically, when a record has conflicting edits (e.g. a calendar event that has been deleted in Outlook and also modified on Android), the edit with the most recent modified time is kept.

    Here are a couple of things to check that may resolve the issues for you:

    1. Make sure that Google sync is off on your Android. With Google sync on, it could be the case that Google is updating the records on Android after you have changed/deleted them on Outlook, so that the Android changes are always kept, instead of the Outlook ones.

    2. Make sure that the system time on your PC and the system time on your Android are the same.
    Hi Ben, thank you very much for your questioning,

    First of all : it seems weird too me as such a bug should have already been found for a while on your side if it was general ; I'm pretty sure of that.

    1.
    Because I have found a couple of bugs about Native Android & Google sync, I do not use them at all : just DJO. I have put one time at the start my contacts to Android to be able to use my phone as a phone, that's all.

    2.
    I have just reproduced the fact with DJO 1.6.3 now :
    - I modify the title of event1 in DJO.
    - I wait minutes.
    - I modify the title of event1 in Outlook.
    - I sync...
    - And, the oldest modified event1 in DJO is found on both sides !
    The time is exactly the same : 20h30. But, you know well that Android copes with the DST (daylight saving time) in a strange manner that works well with Outlook/DJO presently and also with syncing with Google. I'm in France, and my TZ (time zone) is GMT+1, but in summer, the DST is +1h, and Android put a TZ with GMT+2 to reflect that !?!!! Perhaps not a good idea, bu that's the case and for the moment it works for me even if I'm afraid of what will happen in winter. So, I'm TZ=GMT+2=20h30, and my PC is TZ=GMT+1+DST(1h)=20h30. You can see many forums discussions in America about that problem.
    Anyway, the syncing works perfectly with DJO with these parameters, but, perhaps, you forget to check the modification time of events against TZ+DST ?

    Regards

    French / Windows XP SP3 / Outlook 2003 SP3 / CL Pro 4.0.4006 / Samsung Galaxy S / Android 2.1 / DJO 1.6.3 / Param = days back 30 + sync both ways + deleted both + sync alarms + cleared records + no Native Android & Google sync

  8. #8
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    A remark, your forum works exactly like Android to manage DST with TZ ; this at the bottom :
    All times are GMT +2. The time now is 10:00 AM.
    Powered by vBulletin Version 4.0.2
    Copyright 2010 vBulletin Solutions, Inc. All rights reserved.
    (C) 2010 by CompanionLink Software, Inc. All Rights Reserved.
    Regards

    French / Windows XP SP3 / Outlook 2003 SP3 / CL Pro 4.0.4006 / Samsung Galaxy S / Android 2.1 / DJO 1.6.3 / Param = days back 30 + sync both ways + deleted both + sync alarms + cleared records + no Native Android & Google sync

  9. #9
    Junior Member
    Join Date
    Aug 2010
    Posts
    5

    Thanks, that helped.

    Your advice, to stop syncing with Google calendar, seems to have done the trick and enabled my device deletes to be reflected in Outlook. What I did was to go into DJO Settings, Sync Settings, and then unchecked Sync with Android Calendar App. Then, in CL Setup: Outlook Settings, Applications tab: Calendar transfer set to "Android to Outlook", Primary Database set to Android.

    Thanks!

    Quote Originally Posted by Ben View Post
    larentdjo and Skip-A - Both of your reports sound like modified time issues. Basically, when a record has conflicting edits (e.g. a calendar event that has been deleted in Outlook and also modified on Android), the edit with the most recent modified time is kept.

    Here are a couple of things to check that may resolve the issues for you:

    1. Make sure that Google sync is off on your Android. With Google sync on, it could be the case that Google is updating the records on Android after you have changed/deleted them on Outlook, so that the Android changes are always kept, instead of the Outlook ones.

    2. Make sure that the system time on your PC and the system time on your Android are the same.

  10. #10
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    Hi, to stop syncing with Google Calendar was not enough to me ; the 08-12-2010 08:44 PM post above is always true for me. Regards.

Closed Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts