Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Alarm problems with Marshmallow

  1. #1
    Senior Member
    Join Date
    Oct 2011
    Posts
    438

    Alarm problems with Marshmallow

    My phone has recently updated to Android 6.0 Marshmallow. Since then I have been having problems with the Alarms if the phone is stationary. My phone is often not in my pocket, it is therefore stationary. I understand that Marshmallow has a clever battery saving trick which shuts down some functions when the phone is stationary for some time. Could this be causing the Alarm not to sound until the phone is moved.

    Quite often I pickup the phone and a alarm will sound that is overdue.

    Is there an Android setting that I can change to make sure Alarms sound when the phone is stationary?
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  2. #2
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    Cecil, we don't have a Motorola phone here to check.

    Look on the phone for a new App called "Optimizing" or something like that. In that app, set the status of DejaOffice to "Never Optimize". This is a new Android feature that does as you say - turns off apps when the phone is idle.

  3. #3
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    Hi DJOCTO

    Thanks for your help.

    I found a setting under

    Settings/Sound &notifications/App notifications/DejaOffice/Treat as priority.

    I will set a test event and test this and report back.
    Last edited by Cecil; 05-11-2016 at 11:38 AM.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  4. #4
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    This setting does not seem to have helped with the problem.

    First test yesterday failed as phone rang just before alarm was due.

    Test this morning alarm sounded 6 minutes late and then did not sound again until 45 minutes later when I picked up the phone. Alarms are set to persistent 15 minutes.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  5. #5
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    I have found the setting you were talking about under

    Settings/Battery/Menu/Battery optimisation/(Tap "Not optimised")/All apps/Scroll to Dejaoffice/Don't Optimise.

    The process is long winded and not obvious for inexperienced users.

    If I am reading this article properly the developer can set Dejaoffice to ignore the Doze settings

    https://developer.android.com/traini...nderstand_doze

    Setting Dejaoffice to ignore the Doze could perhaps avoid poor reviews in Play Store from Marshmallow users.
    Last edited by Cecil; 05-18-2016 at 02:01 AM.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  6. #6
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    Still having problems so have now raised a support ticket for this issue.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  7. #7
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    Any progress on this?

    Starting to get a bit annoying.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  8. #8
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    We are working on a system change that should fix the Alarm issues.

    The issue is that Android OS is no longer being responsive to our alarms. The fix is to update the internals of the App to Android 6.0 specific, rather than "All Android Versions". It's a full change on the manifest and build chain. There are a lot of ramifications. I'm hoping to have this in beta by July 4th holiday.

  9. #9
    Senior Member
    Join Date
    Oct 2011
    Posts
    438
    Thanks for the reply. I understand the challenges of this update and the need to keep all Android versions able to respond to the Alarms generated by Dejaoffice while Android 6.0 is in doze mode.
    Cecil

    Motorola Moto G5 Android 8.1.0
    DJO 4.4.11 (1091) Companionlink 7 (7046)
    ACT 16
    USB Sync
    Syncs to Android Contacts App only

    Lenovo Tab 4 8
    DJO 4.4.11(1091)
    WiFiSync
    Syncs to Android Contacts App only

  10. #10
    Senior Member
    Join Date
    Nov 2011
    Posts
    138
    Any progress on this alarm issue with Android6? I ask 'cos I am considering a Galaxy s7 which comes with Android 6.0.1 but do need working alarms on it
    -Frans

    Samsung Galaxy s7, stock rom 8,0, not-rooted
    DJO 4.4.12 (1099) , CompanionLink 8022
    Outlook 2016 (32bit), sync via DejaCloud (native sync Contacts only)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •