Results 1 to 5 of 5

Thread: CompanionLink Task Deletes Not Working

  1. #1
    Senior Member
    Join Date
    Oct 2012
    Posts
    127

    CompanionLink Task Deletes Not Working

    Using the last several CompanionLink Betas, when I delete a task in Outlook it does not sync to DejaCloud. I have to do a manual sync to get it to sync. I went back to beta version 7047.22 which which works.

    (Sorry, I put this in the wrong forum)
    Last edited by Eagle 3; 09-16-2017 at 08:11 AM.
    PC: Windows 7, 64 bit
    CompanionLink build #: Companionlink 7 for Outlook, Build 8019.7
    Data Manager App: Outlook 2010 64-bit
    Mobile Device: Samsung Galaxy Note 8 (SM-N950F);
    OS: Android 7.1.1, Build #: N950FXXU1AQKG
    DejaOffice version#: 4_4_7_1069
    Sync Method with CompanionLink: DejaCloud
    DejaOffice Sync Settings for Contacts: Selected, sync with Android, Account = DejaOffice.
    DejaOffice Sync Settings for Calendar: Not selected.
    Native Contacts Account: DejaOffice

  2. #2
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    Any delete is a bit problematic. Outlook does not actually set the modified date on the delete (you can see this in OL if you look). Normally the system picks this up when another record is added or changed.

    In CompanionLink, in the Options menu (main screen) there is a checkbox for "Optimized update sync". For you, is this checked or unchecked?

    Normally unchecking this will make the system more sensitive to a deleted item. It does this by checking more thoroughly (more cpu, longer sync times) for each sync.

  3. #3
    Senior Member
    Join Date
    Oct 2012
    Posts
    127
    I unchecked "Optimized update sync" and the task delete still doesn't work. It only happens with the latest betas, beta version 7047.22 works just fine. So, I would think that something changed in the latest betas that is causing the problem.
    PC: Windows 7, 64 bit
    CompanionLink build #: Companionlink 7 for Outlook, Build 8019.7
    Data Manager App: Outlook 2010 64-bit
    Mobile Device: Samsung Galaxy Note 8 (SM-N950F);
    OS: Android 7.1.1, Build #: N950FXXU1AQKG
    DejaOffice version#: 4_4_7_1069
    Sync Method with CompanionLink: DejaCloud
    DejaOffice Sync Settings for Contacts: Selected, sync with Android, Account = DejaOffice.
    DejaOffice Sync Settings for Calendar: Not selected.
    Native Contacts Account: DejaOffice

  4. #4
    Senior Member
    Join Date
    Oct 2012
    Posts
    127
    Apparently this was fixed in the beta 7047.40. It works in beta 7047.41 too. Thanks.
    PC: Windows 7, 64 bit
    CompanionLink build #: Companionlink 7 for Outlook, Build 8019.7
    Data Manager App: Outlook 2010 64-bit
    Mobile Device: Samsung Galaxy Note 8 (SM-N950F);
    OS: Android 7.1.1, Build #: N950FXXU1AQKG
    DejaOffice version#: 4_4_7_1069
    Sync Method with CompanionLink: DejaCloud
    DejaOffice Sync Settings for Contacts: Selected, sync with Android, Account = DejaOffice.
    DejaOffice Sync Settings for Calendar: Not selected.
    Native Contacts Account: DejaOffice

  5. #5
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    I came back today to say this... You already found it. Programmer made a change:

    Programmer note:
    Looks like deletes weren't triggering an autosync if OL was set as the PIM instead of the HH. Deletes would still be picked up if another change was made, as this only affect the IsUpdated() logic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •