Results 1 to 5 of 5

Thread: Events not always deleted

  1. #1
    Member
    Join Date
    Nov 2010
    Posts
    83

    Events not always deleted

    Hi,

    I am using Outlook 2013 and I am synchronizing via DejaCloud.

    When I create an event in DJOA ( and synchronizing it) and if I after delete this event in Outlook, after synchronizing Outlook with DejaCloud, it is, sometimes,
    not deleted in DejaCloud and of course it still appears in DJOA.

    I have as settings in CL: (Deletion Preferences ) : " Records deleted in either DejaCloud or Outlook will be synchronized.

    Thank you for help,

    Daniel

  2. #2
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    danielf - Are you sure it gets deleted on the cloud? I suspect the problem is from PC to Cloud.

    For CompanionLink to see a deleted record takes a little magic. Outlook puts the record in the deleted items folder, but it does NOT update the last modified date. So when CompanionLink scans for recently modified records, the deleted record isn't apparent.

    1. We have an Add-In for Outlook. Outlook tends to turn it off. So check Outlook Add-Ins and make sure it is active.

    2. We also check record counts in folders. So sometimes when a delete isn't found, and you add another record, the system figures out automatically that there must be a delete and will process it.

    3. Also, once a day CompanionLink does a full sync, so the delete should go then.

    From DejaCloud to Handheld the deletes are usually very dependable. We are not dependent on another company's API for this.

    So check the status in the cloud and see if it is on the PC side.

  3. #3
    Member
    Join Date
    Nov 2010
    Posts
    83
    Quote Originally Posted by DJOCTO View Post
    danielf - Are you sure it gets deleted on the cloud? I suspect the problem is from PC to Cloud.

    For CompanionLink to see a deleted record takes a little magic. Outlook puts the record in the deleted items folder, but it does NOT update the last modified date. So when CompanionLink scans for recently modified records, the deleted record isn't apparent.

    1. We have an Add-In for Outlook. Outlook tends to turn it off. So check Outlook Add-Ins and make sure it is active.

    2. We also check record counts in folders. So sometimes when a delete isn't found, and you add another record, the system figures out automatically that there must be a delete and will process it.

    3. Also, once a day CompanionLink does a full sync, so the delete should go then.

    From DejaCloud to Handheld the deletes are usually very dependable. We are not dependent on another company's API for this.

    So check the status in the cloud and see if it is on the PC side.


    Quote Originally Posted by DJOCTO View Post
    danielf - Are you sure it gets deleted on the cloud? I suspect the problem is from PC to Cloud.

    For CompanionLink to see a deleted record takes a little magic. Outlook puts the record in the deleted items folder, but it does NOT update the last modified date. So when CompanionLink scans for recently modified records, the deleted record isn't apparent.

    1. We have an Add-In for Outlook. Outlook tends to turn it off. So check Outlook Add-Ins and make sure it is active.

    2. We also check record counts in folders. So sometimes when a delete isn't found, and you add another record, the system figures out automatically that there must be a delete and will process it.

    3. Also, once a day CompanionLink does a full sync, so the delete should go then.

    From DejaCloud to Handheld the deletes are usually very dependable. We are not dependent on another company's API for this.

    So check the status in the cloud and see if it is on the PC side.

    Hello,

    Thank you for your answer.

    Indeed it doesn't get deleted in DejaCloud.
    I checked the Add-In for Outlook (CompanionLink Outlook Add-In ) and it is active.

    Daniel

  4. #4
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,222
    Daniel,

    That makes more sense to me. It's because we handle Outlook with Deletes-by-omission, rather than Positive Deletes which we do with platforms we can control.

    So Try it again. Maybe clarify whether you are deleting a recurring or single instance event.

    The pickup will be better if you turn Optimized sync off. The setting in CL7 is in the File Options menu, uncheck it. In CL8 the menus have been removed, but you will find it as a checkbox in the Advanced Settings tab.

  5. #5
    Member
    Join Date
    Nov 2010
    Posts
    83
    Hello,

    Thank you for your answer.
    I am only deleting single instance event.
    I have turned "Optimized sync off". and will let you know if it happens again.

    Daniel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •