+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Alarms defaulting to ringtone

  1. #11
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    Thanx for the quick reply, Thomas!

    So I uninstalled, reinstalled from the link and doubled checked that both task and calendar alarms were default. I checked default through Android settings and everything was lined up. I did NOT check with a dummy appt.

    One thing with the old build you linked - selecting the alarm settings from DJO brought up a blank white screen. I had to select the 3-button menu in the upper right to get the normal alarm screen options. Same thing after I updated.

    I then updated DJO to build 1069 just posted today. I checked it with a dummy appt, with the default DJO settings (no adjustments). DJO once again reverted to using the Android ring alarm rather than the Android default notification ringtone.

    Any other suggestions at this point?

    Make it a wonderful weekend!

    KATrimels

  2. #12
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    Hi again Thomas!

    I'm just wondering if there's something I'm missing... or whether y'all are working on a fix. Can you please let me know - especially if I'm missing something on my end.

    Thanx and make it a wonderful rest of your Wednesday!

    Keith

  3. #13
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,196
    KAT sorry for the non response. Thomas is out on vacation for a bit.

    We are still working through what Android wants out of this.

    In Android Settings, go to "Sounds and Vibration".

    On this screen select "Notification sounds" - set the desired sound here.

    On the same screen select "Volume". This gives volume sliders for Notifications.

    This is what it should be using now for Android 8 devices.

    In Android Settings, go to

  4. #14
    Senior Member
    Join Date
    Nov 2011
    Posts
    136
    For Android 8 on my Samsung Galaxy s7 I have to go to Android Settings -> Notifications -> Deja Office and then click on 'Calendar Alarm' or 'Task Alarm' (no idea what 'Silent' does there) and set the sound you want for it.
    -Frans

    Samsung Galaxy s7, stock rom 8,0, not-rooted
    DJO 4.4.5 (1069) , CompanionLink 8018
    Outlook 2016 (32bit), sync via DejaCloud (native sync Contacts only)

  5. #15
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    Thanx for the follow up, CTO.

    I have made those changes - and they are not being picked up by DJO. That's why Thomas directed me to fall back to the last version of DJO that controlled the alert settings, make those changes in DJO and ensure the settings are in Android 8/8.1, then update DJO back to current.

    My presumption is that the hope was that those selections would stick through the update... they didn't. And I've checked the adjustments again through Android settings with no luck.

    Now, I'm looking forward to a solution so I can differentiate between a call and an appointment alarm.

    Also, I've noticed today that the recurring alarm setting (if not touched) seem to not take changes. It was at the default of every 1 minute.

    I changed it to every 5 minutes, and it still went off every 1 minute for my meeting that started at noon... but I hadn't rebooted the phone or made any calendar adjustments or synced. So I'm not sure if that impacts the when that changed setting should grab.

    I'll look to hear back from y'all with any additional ideas I should try for DJO calendar picking up the phone alarm tone vs. picking up the default alarm tone.

  6. #16
    Senior Member
    Join Date
    Nov 2011
    Posts
    136
    Did you try the settings under Android Settings -> Notifications -> (tap on text, not on toggle, saying) Deja Office ? There you can select 'Calendar Alarm' and set the ringtone for it. It worked for me, but could be Samsung specific.
    -Frans

    Samsung Galaxy s7, stock rom 8,0, not-rooted
    DJO 4.4.5 (1069) , CompanionLink 8018
    Outlook 2016 (32bit), sync via DejaCloud (native sync Contacts only)

  7. #17
    It looks like Android 8 has moved the option to change the notification. I am able to change the notification tone by using the following steps:

    1. Open the Android Settings
    2. Go to Sound then tap Notification
    3. Select the appropriate tone here
    Last edited by Chris L; 06-21-2018 at 12:37 PM. Reason: typo

  8. #18
    Junior Member
    Join Date
    Jul 2012
    Posts
    7
    Under the Android 8.1 I have on my OnePlus 5T, this is where the sound settings are:
    1. Android settings
    2. Sound & vibration
    3. Look under Ringtone - there are choices for each of the following: Phone, SMS and Default notification

    Phone and Default notification are different, but DJO keeps picking up the Ringtone rather than the Default notification.

  9. #19
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,196
    Ok, this is sent to the developers. The issue is that we had to target Android 8, which ended up changing the behavior of Notification sounds. The settings location of notifications seems to indicate this is a bit half-baked on the Android OS side. We are working on a better solution here.

  10. #20
    Senior Member
    Join Date
    Nov 2011
    Posts
    136
    Quote Originally Posted by KAT View Post
    Under the Android 8.1 I have on my OnePlus 5T, this is where the sound settings are:
    1. Android settings
    2. Sound & vibration
    3. Look under Ringtone - there are choices for each of the following: Phone, SMS and Default notification

    Phone and Default notification are different, but DJO keeps picking up the Ringtone rather than the Default notification.
    Don't you have Deja Office specific notification settings under Settings->Notifications on 8.1 ? That's where I found the Calendar/Task sound settings (under Deja Office) and I could set them there just fine.

    This is what I see under Android Settings->Notifications->Advanced->Deja Office (I can set sound when tapping on the text part of those) :
    Attached Images Attached Images
    Last edited by fpostma; 06-22-2018 at 08:22 AM.
    -Frans

    Samsung Galaxy s7, stock rom 8,0, not-rooted
    DJO 4.4.5 (1069) , CompanionLink 8018
    Outlook 2016 (32bit), sync via DejaCloud (native sync Contacts only)

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts