Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: USB sync problems

  1. #1
    Senior Member
    Join Date
    Nov 2016
    Posts
    129

    USB sync problems

    I've started having sporadic problems doing a USB sync - everything is connected and open properly, then when I start the sync from DJO I see no response in CLO in the computer. Eventually I stop it in DJO, and trying again usually is no better. Generally restarting both the phone and computer helps, but not always.

    Both the phone and computer were totally shut down last night. This morning, I made a number of changes in Palm, and a few in DJO and then started the sync from DJO. CLO showed no response, and I was able to close it. I restarted both the phone and the computer, and suddenly CLO popped up in the computer and showed that it was syncing. It finished properly, but not everything matches now. It appears that the few things I had changed in DJO did not sync to Palm.

    Any suggestions for getting it to respond to a sync properly? I may try doing a re-read of Palm for the next sync, and then see if everything matches on both sides.

    Or is there a way to make CLO clear out a pending sync and make a fresh start?

    Thanks,
    Marjory
    ===============================================
    Samsung Galaxy S10e, Android 9, security patch level, May 1, 2019
    DJO 4.4.21, build 1140; CL 8038
    Win10 x64, Fall Creator/March 2019 update, v 1903, last major update 6/20/19, last monthly update 6/28/19
    PalmDesktop 4.2

    Most recent Win update - July 2, 2019, update for Office 2010 Filter Pack (KB3114879)

    USB sync -- manual syncing, as needed
    Not syncing to native Android calendar or contacts

  2. #2
    DejaOffice Team Member
    Join Date
    Dec 2010
    Posts
    2,479
    Marjory,

    Are you sure the Phone is appearing as a drive on the PC when you connect it? This sounds like a bad cable or possibly try a different port on the PC.

    The Reread would be the way to go, but if the changes were in the DejaOffice side, you would want to Reread Android, not the Palm side.

    Restarting the PC as you did should cause CompanionLink to open cleanly on the PC startup.

  3. #3
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    Quote Originally Posted by Thomas View Post
    Are you sure the Phone is appearing as a drive on the PC when you connect it? This sounds like a bad cable or possibly try a different port on the PC.
    With this phone, "Galaxy S10e" immediately appears as a drive with phone and card as subfolders in it each time I connect it. That's really convenient for accessing photos and such, as well as not having to "connect/disconnect the phone to USB" in DJO for each sync. It also charges while plugged in this way. The settings do have a lot of options:

    USB controlled by:
    - connected device
    - this phone ***
    Use USB for:
    - transferring files ***
    - system update
    - MIDI
    - transferring images
    -charging phone only

    *** When I first used it, these were set for This phone, and Transferring files, and I have left it that way so far.

    It's the cable that came with the phone 2 weeks ago, presumably brand new from Samsung.
    I will try the other port, though this computer only has 2, plus I have a USB hub. But I normally connect directly from phone to computer.

    Quote Originally Posted by Thomas View Post
    The Reread would be the way to go, but if the changes were in the DejaOffice side, you would want to Reread Android, not the Palm side.
    Good point! I tend to change things on both sides sporadically during the day, then when I'm going to sync I might look at both at once and move more things forward in Palm which is much easier to just drag to another hour or day.

    Quote Originally Posted by Thomas View Post
    Restarting the PC as you did should cause CompanionLink to open cleanly on the PC startup.
    I thought so, but it continued to be tangled up sometimes. I'll watch what happens. I'll also watch Task Manager if I just close CLO, to be sure it isn't still running as a background task.

  4. #4
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    Quote Originally Posted by marjoryb98 View Post
    With this phone, "Galaxy S10e" immediately appears as a drive with phone and card as subfolders in it each time I connect it. That's really convenient for accessing photos and such, as well as not having to "connect/disconnect the phone to USB" in DJO for each sync. It also charges while plugged in this way. The settings do have a lot of options:

    USB controlled by:
    - connected device
    - this phone ***
    Use USB for:
    - transferring files ***
    - system update
    - MIDI
    - transferring images
    -charging phone only

    *** When I first used it, these were set for This phone, and Transferring files, and I have left it that way so far.
    Now I absolutely cannot find these settings in the phone! I do have a screen capture of them that I did the evening of the day I bought it, so it probably popped up the first time I connected the phone to the computer at home. (An initial data transfer from the old phone had been done at the store using Samsung's Smart Switch app.)

  5. #5
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    In CLO - Settings, Advanced, Applications tab - under Reread, what does Optimized Update Sync mean or do? Mine has been checked at least since I updated to Build 8038. Does that have any effect if I am not doing a reread?

  6. #6
    DejaOffice Team Member
    Join Date
    Dec 2010
    Posts
    2,479
    Marjory,

    We would always need the phone connected in "transferring files" mode for the PC to see the phone's storage. If the PC can not "see" the phone, we can not make the connection for the USB. Normally the best way to find this is connecting the phone, sliding down from the top of the phone to pull down the Notifications overlay. If the USB is connected correctly, there should be an option showing "Connected for" and list USB Charging, Transferring Files etc. You can tap on this to change the modes if it says Charging only. Not seeing something about Charging or Transferring files would indicate a Cable issue.

    The Optimized update sync just helps to make the sync faster by only looking for changes.

  7. #7
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    I think I've found at least a solution/workaround. Everything had been shut down overnight. In the morning I started both Palm and DJO, and made some changes in each. Completely closed DJO in the phone, including closing it in the recent tasks list, then reopened it. When I started a sync from the phone/DJO, CLO did not respond.
    This time I left DJO open in the phone, still trying to start the sync, and closed CLO in the computer. I also closed CLO in background tasks this time. When I started CLO again, the sync immediately started.

    Since then, I've been taking the extra steps of completely closing CLO and then reopening it before doing a sync, and so far it has worked properly.

    Is there perhaps a way for me to stop CLO from running as a background process when I exit from it?

  8. #8
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    Quote Originally Posted by Thomas View Post
    Marjory,

    We would always need the phone connected in "transferring files" mode for the PC to see the phone's storage. If the PC can not "see" the phone, we can not make the connection for the USB. Normally the best way to find this is connecting the phone, sliding down from the top of the phone to pull down the Notifications overlay. If the USB is connected correctly, there should be an option showing "Connected for" and list USB Charging, Transferring Files etc. You can tap on this to change the modes if it says Charging only. Not seeing something about Charging or Transferring files would indicate a Cable issue.
    Well, there's something new or strange about this phone with Android 9 - any time I plug it in to the computer, File Explorer always immediately sees the phone and the card as drives. I can access photos etc on both the phone and the card without doing anything extra. There definitely is nothing about connections when I pull down the notifications on the phone.

    Anyway, please see what I just posted about a workaround, before I saw this note

  9. #9
    DejaOffice Team Member
    Join Date
    Dec 2010
    Posts
    2,479
    Marjory,

    You can control this by A, ensuring Auto Sync is set to Manual and B, CompanionLink is not set to Run At Startup.

    1. Open CompanionLink
    2. Click Settings on the left, Advanced in the bottom left

    Under the General Tab uncheck Run At Startup.

    3. In the same Advanced Settings, find the Advanced Settings tab at the top and ensure the Auto sync is set to Manual.

  10. #10
    Senior Member
    Join Date
    Nov 2016
    Posts
    129
    Quote Originally Posted by Thomas View Post
    Marjory,

    You can control this by A, ensuring Auto Sync is set to Manual and B, CompanionLink is not set to Run At Startup.

    1. Open CompanionLink
    2. Click Settings on the left, Advanced in the bottom left

    Under the General Tab uncheck Run At Startup.

    3. In the same Advanced Settings, find the Advanced Settings tab at the top and ensure the Auto sync is set to Manual.
    Both of them were already set as you suggested. I'm doing fine so far with my new routine of completely closing CompanionLink after each sync. This time of the year while I have to use USB rather than WiFi, I'm generally only syncing a few times per day. Plus, with the phone always connecting as a drive, I don't have to fuss with switching to file transfer after starting a sync (that I had to do with the old S5, Android 6 phone).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •