Results 1 to 7 of 7

Thread: Alarm problem when in a time zone away from home

  1. #1
    Member
    Join Date
    Feb 2011
    Posts
    42

    Unhappy Alarm problem when in a time zone away from home

    In recent releases of DejaOffice, I have the following problem. When I am in a time zone away from home, the alarms misbehave. If I turn off the alarm for an event or change when it is to ring, the alarm rings according to the original setting as well as the new one. When it rings after I turned off the alarm notification for the event and I open the notification, it does not have the usual format with a snooze button, but it rather has an almost blank page with a back arrow. Sometimes the alarm problem is worse in that the alarm for the event keeps going off. In that case the only way I can get DejaOffice to work normally is to rebuild the Calendar.

    I have a Samsung Galaxy S8 running Andoid 9 kernel version 4.4.153 and DejaOffice 4.4.24 (build 1167).

  2. #2
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,293
    Mel, thanks for the heads up. In DejaOffice Settings, General Settings, what do you have for Time Zone Shift? I assume "No".

    In order to not shift appointments, DejaOffice needs to reset the alarms database when it senses that the phone has shifted time zones. Android OS is based on Linux, so all internal times are GMT. So when you go from Eastern time to Central time, your appointment is still at 8am. But to the phone, the time zone has shifted from 13:00 to 14:00 GMT, and the software needs to make this shift.

    You are right to do the Rebuild Calendar Display. This function does reset the entire alarms table. The next 10 alarms are downloaded to Android OS, and kept by the OS in a table. So this has to be rewritten when the phone changes time zones.

    This is supposed to be automatic. We'll get that fixed. Until then, run the Rebuild if you see it misbehave and that will reset the alarm table in the Android OS.

  3. #3
    Member
    Join Date
    Feb 2011
    Posts
    42
    I have always had Time Zone Shift set to YES.

    Mel

  4. #4
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,293
    Mel,

    So assuming you are in New York, if you make an appointment in Chicago at 10am with an alarm at 9:45, and then you fly to Chicago, you want the appointment to shift to 8am with an alarm at 7:45.

    And the problem you are reporting is that it rings at 9:45 in Chicago instead of the shifted time. Is that right?

    I'll need to review time zone shift with the developmer. We really need some better wording for this option. Most people want Time Zone Shift "No" so that the 10am Chicago Appointment stays at 10am when I go to Chicago.

    Wayland

  5. #5
    Member
    Join Date
    Feb 2011
    Posts
    42
    In general, my meetings are attended via video conference by people in various time zones in the US and Europe. Say I make a calendar entry when I am in Chicago for a video conference starting at 9AM Central time. When I go to the East Coast, I want that meeting to appear on the calendar at 10AM (Eastern time), with the alarm ringing at 9:45.

  6. #6
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,293
    Got it. That's the right setting.

    I submitted a fix to the developer. So the fix is that when the phone is in a new time zone, and the setting is to "shift" i.e. keep the same UTC time, we still need to refresh the alarms. Probably that is not done since for an android the action to "shift" means "do nothing".

  7. #7
    Member
    Join Date
    Feb 2011
    Posts
    42
    Thanks for the prompt response!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •