Closed Thread
Results 1 to 9 of 9

Thread: Syncing contacts with android too slow

  1. #1
    Junior Member
    Join Date
    Oct 2010
    Posts
    9

    Syncing contacts with android too slow

    I have checked the option to sync with android contacts. After that, each sync operation takes up to 20 minutes to finish.

    I have already tried all the options to come back, but nothing has worked out. All the gmail-just-one-email contact have moved to my android phone (but not to the Palm Desktop).

    How can I delete the gmail contacts from my phone? Is there another solution to solve this issue?

    Thanks,

    agandini

  2. #2
    Senior Member DJOCTO's Avatar
    Join Date
    Apr 2010
    Posts
    2,210
    Here are some steps to completely clean out an Android phone, and re-establish the databases from the PC.

    ====If you have contacts in Google you wish to keep=======

    Turn off Google Contacts sync on the Android:
    1. Open Settings. Select "Accounts", "Accounts & Sync", or "Data Synchronization"
    2. Select the Google account (if available)
    3. Uncheck Contacts and/or Calendar
    NOTE: With Auto-Sync turned off, your Contact and Calendar data will no longer be sent to Google.

    Manually clear out contacts in the native app:
    1. Go to Settings/Applications/Manage Applications/Contacts Storage
    NOTE: *If user goes to manage applications and "contact storage" isn't there, hit the menu key, then filter, set to see all not just the running?.
    Locate Contacts storage now

    2. Select Clear Data
    NOTE: The "Clear Data" option is not available on Droid X running Android OS 2.1


    ====If you have contacts in Google that you DO NOT want======

    Clear out contacts in Gmail
    1. Log in to your Gmail account and clear out your contact list.
    2. Let this sync to Android so the Android list is also clear.

    Turn off Google Contacts sync on the Android:
    1. Open Settings. Select "Accounts", "Accounts & Sync", or "Data Synchronization"
    2. Select the Google account (if available)
    3. Uncheck Contacts and/or Calendar
    NOTE: With Auto-Sync turned off, your Contact and Calendar data will no longer be sent to Google.


    ====Clear everything out of DejaOffice====
    1.If your device has a keyboard, open DejaOffice to the main screen and type "RESET"
    2.If your device does not have a keyboard tap and hold the menu button and then type "RESET"
    3.Select "Yes" to Reset the Database
    NOTE: RESET Method does not work on Galaxy S phones
    4.If this still does not work, connect the phone to the PC
    5.Mount the phone in USB Storage mode
    6.On the PC look for the clusb folder and delete it
    7.Unmount the phone from the PC/Turn off USB Storage mode



    ===+Clean up your PC data and re-sync=======
    1. On your PC, make sure your contact manager is free of duplicates and any unwanted data.
    2. Finally, in CompanionLink select Purge and Reload from the PC. This will replace all the data on the phone.

  3. #3
    Junior Member
    Join Date
    Oct 2010
    Posts
    9

    Thanks!

    Thanks! It worked!

    agandini

  4. #4
    Junior Member
    Join Date
    Jan 2011
    Posts
    2
    I was having the same problem, at least half an hour to sync - this fixed it, thank you! I was (an always am) concerned about duplicating records in outlook (i have 2000+ contacts and the sync finds almost 1000 calendar records) but all worked out fine. I did delete all the gmail contacts first. now my sync (outlook -> dejaoffice -> android) is only a couple of minutes. I have turned off syncing to gmail, as I don't need it.

  5. #5
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    I have deleted the clusb folder to start anew, but the issue is here again : the Android Native Contacts database is fully synced too often even if no modifications happened and it takes more than 10 minutes to complete...

    XP FR / Outlook 2007 / DJO 1.9.8 + CLP 4.0.4026 paid license / Samsung Galaxy S / Android 2.2 / Settings = 30 days back + sync both ways + sync deletions + sync alarms + cleared records + native Android contacts sync but no Google sync

  6. #6
    Junior Member
    Join Date
    Jan 2011
    Posts
    1
    Same problem-- but worse. Syncing to my Droid 2 Global takes hours (literally). I have tried all of the above-- but no luck. This included cleaning out the phone. Plus, I have stopped as many apps as possible on the phone (thinking that they may be interfering). 4000 contacts. Using CompanionLink Professional 4.0 to sync Act (contacts) and Outlook (calendar). Any ideas?

  7. #7
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    That's not "technically" worst : I have just 174 contacts to sync rather than you with 4000 ! Thus, 10 minutes for me, and hours for you...
    The fact is that, before the version DJO 1.9.8, only the data to be synced was really synced : this was the case for me ; I have tested it. Now, we must wait very often for a full syncing...

  8. #8
    Junior Member
    Join Date
    Jan 2011
    Posts
    2

    update to previous post

    so the sync from outlook to dejaoffice is now very quick (status says "quick sync" and takes less than a minute for 2000+ contacts.) I sync over my wifi and so I only have to stay in range for this long. BUT then the sync from Deja Office to Android contacts starts, and it is at least a half hour. it will run in the background, and is all on the phone, but STILL.

  9. #9
    Senior Member
    Join Date
    Jul 2010
    Posts
    389
    I think this is because DJO does a full sync too often even with no contacts modifications ; this kind of full sync shall happen with "read android data" only.
    During that time, very long, it is impossible to use DJO or to sync a second time if necessary...

Closed Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts