+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Sync does not work for Epic 4G under Froyo

  1. #1
    Junior Member
    Join Date
    Jul 2010
    Posts
    11

    Sync does not work for Epic 4G under Froyo

    Hi,
    I am running the leaked Froyo release for the Sprint Epic 4G and I thought you all should know that it "breaks" syncing for Deja Office. I have tried it over and over, in multiple different ways and the way it mounts when you attach the USB cable seems to prevent consistent, reliable syncing. While I dont expect you to rewrite software to fit a leaked OS release, this aspect seems pretty much done in the leak and is quite different than it was under Android 2.1. I should also mention (as several posters have) that the stickied Galaxy S instructions in the forum do not work on the Epic either (even under Android 2.1). It has been hit or miss all along with Deja Office, but I think the Froyo update will require some significant reworking. If you would like more details about this, please let me know.

  2. #2
    DejaOffice Team Member Kaena's Avatar
    Join Date
    Apr 2010
    Posts
    128
    Hi dr_gibberish,

    Thanks for the heads up, we'll definitely be looking to support Froyo for the Galaxy S devices once the update is publicly available.

    I the meantime, have you tried syncing via Wi-Fi? I'm guessing the update from 2.1 -> 2.2 doesn't really affect the Wi-Fi protocol.

  3. #3
    Junior Member
    Join Date
    Feb 2011
    Posts
    6
    Quote Originally Posted by dr_gibberish View Post
    Hi,
    I am running the leaked Froyo release for the Sprint Epic 4G and I thought you all should know that it "breaks" syncing for Deja Office. I have tried it over and over, in multiple different ways and the way it mounts when you attach the USB cable seems to prevent consistent, reliable syncing.
    I have upgraded to the official FROYO release on my Epic and Deja Office does not work with it. It fails with the message "Plug in the USB cable before starting sync" (or something very similar to that. Like the previous poster, I have tried every which way, but to no avail.

  4. #4
    Junior Member
    Join Date
    Jul 2010
    Posts
    11
    So I have figured out a workaround that seems to sync ok. (By the way, I do not have wireless sync, so it may work.) Here is what I do:

    First, my setup:
    1) I am running latest beta of Deja Office - 1.10.6
    (I am set NOT to sync with default Android contacts and calendar apps (under Deja Office settings - Sync Settings))
    2) I am running latest companion link 4.0 Build 4031
    3) Syncing with my Windows 7 64-bit laptop

    What I do:
    1) On the phone, Under Settings-Display-Screen timeout, I set the screen timeout to 10 minutes
    (Not sure if this really makes a difference but I was having some problems if the phone turned off in the middle of this process)
    2) Open deja office and hit sync button - Brief pop-up says "Please connect the USB cable to your PC before hitting the sync button"
    3) Open companion link setup on the computer (so I can see it when sync starts)
    4) Plug USB cable into phone (and PC)
    5) Pop-up comes up on phone with three button options - choose "Mass Storage"
    6) New screen comes up saying "USB Connected" - Then press button on this screen saying "Connect USB Storage"
    7) Warning screen comes up on phone saying it "will stop some applications in use" - hit OK
    8) Timer icon appears on screen, wait for it to connect
    9) Phone screen will turn Orange and you will see sync beginning on Companion Link on PC
    10) Wait until pop-up comes up on CompanionLink saying "PC Sync Complete. Press OK on the phone to complete" - Press the OK button on this pop-up on the PC.
    11) Now go back to phone and press "Turn Off" button at bottom of Orange "USB Connected" screen
    12) Phone will either jump directly to Deja Office or you may have to press back button on phone to get there.
    13) You will see "synchronizing" pop up in Deja Office - wait for it to complete.
    14) "Sync complete" pop up appears in Deja Office - Press OK
    15) Voila! You are synced!
    16) Set your screen timeout back to whatever it was before.

    Hope this helps someone else!
    Last edited by dr_gibberish; 02-23-2011 at 10:27 AM. Reason: Edited for better readability

  5. #5
    Junior Member
    Join Date
    Oct 2010
    Posts
    23
    I have WiFI, and it seems to work fine after the upgrade to 2.2. I did notice a change in the account name, which had a different set of digits following my name. It's been so long since I did a USB synch that I don't recall if that was relevant to that type of synch.

  6. #6
    Junior Member
    Join Date
    Jul 2010
    Posts
    11
    Well, that was much easier to set up than I thought and a heck of a lot easier to use than the steps above. For some reason I was under the impression that it cost extra to do the wireless sync but when I looked that was only for their "hosted" sync.

    For anyone else interested in setting up wireless sync with companionlink, the instructions are here: http://www.companionlink.com/support...roid_Wifi_Sync

  7. #7
    Junior Member
    Join Date
    Feb 2011
    Posts
    3
    The 16 steps above that dr_gibberish posted are almost exactly what I have to do now on my Epic to get it to sync with Outlook since the Android 2.2 update.
    In 2.1 it was working flawlessly (after some initial configuration issues). I would basically plug in the USB and click sync on the Deja home page, and that's it. I vaguely recall not even having to click "mass storage" upon plugging in the USB cable...I think it worked just by choosing Charge mode, but I could be mistaken about that.

    In any case, it certainly wasn't the click and pull fest that it has become since 2.2. The only differences I have to do from what was listed above are the following:

    I MUST have the USB cable connected when I click the sync button, I get the warning, then I must pull the USB cable, then plug it back in, click the connect mass storage button, THEN it will finally start the PC sync process. If I click the sync button first, and THEN plug the USB cable in, the PC sync simply won't happen.

    Also, if I leave it in Mass Storage mode with the USB cable plugged in, when I click on any of the Deja apps (notes, tasks, calendar, or contacts) and then exit them, when I get back to the Deja home page, it goes through a 15-20 second sync process again for some reason. The sync window pops up each and every time I enter and exit a Deja app. So, I have to unplug, then replug the USB cable back in and select Charge mode for that to stop.

    Lots of annoyances since 2.2.

  8. #8
    Junior Member
    Join Date
    Feb 2011
    Posts
    6
    The plug and pull fest method works for me. Thank you!

    It's not quite the same on mine. In fact, I haven't really figured out the exact combination that will work every time without fail, but it does eventually work. Still, it takes me about 5 minutes of focusing explicitly on syncing in order to get through it. I can't use WiFi, so I'm stuck with this method until DejaOffice gets a fix in place.

  9. #9
    DejaOffice Team Member
    Join Date
    Dec 2010
    Posts
    2,346
    Hi Everyone,

    Just want you all to know that we are aware of the frustrations that you are experiencing with this and providing feedback to the Dev team. We will let you know when we have a fix in place. In the mean time thanks to the users who are reporting solid workarounds.

  10. #10
    Junior Member
    Join Date
    Feb 2011
    Posts
    3
    Just an update, I have totally given up on the USB sync with Outlook, and have gone WiFi.
    Working 100% so far via WiFi.
    USB was simply too much of a hassle in it's current state.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts